$re = '/\s?\((.+?)\)\s?/';
$str = 'text1((text2))text2';
$subst = " ($1) ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;