#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!"\s)#([0-9\p{L}]+)(?=[\s,!?.\n][^"]|$)"
Local $sString = "I enjoy #action movies! #Action" & @CRLF & _
"movies are #cool." & @CRLF & _
"" & @CRLF & _
"Color #000000; #ffffff; work fine" & @CRLF & _
"" & @CRLF & _
"<div style=" #something "> - works" & @CRLF & _
"" & @CRLF & _
"#action " - works" & @CRLF & _
"" & @CRLF & _
"" #action - doesn't work" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")