using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Ticket (?:#|ID): (\d+)";
string input = @"[Ticket ID: 309972] New Support Ticket Opened
Ticket #: 656398";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}