package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^
(?P<filename>.+\.cs)
\(
(?P<line>\d+)
,
(?P<col>\d+)
\):\040
(?P<level>\w+)
\040
(?P<error>.+)`)
var str = `Template.cs(24,16): error CS0246: The type or namespace name \`TemplateFrame' could not be found. Are you missing a using directive or an assembly reference?
Mob.cs(20,19): error CS1519: Unexpected symbol \`void' in class, struct, or interface member declaration
Compilation failed: 1 error(s), 0 warnings
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}