#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(person\s*=\s*{[^}]*'name'\s*:\s*')(.*?)(')"
Local $sString = "person = {" & @CRLF & _
" 'name' : 'Jhon Dow'," & @CRLF & _
" 'address' : 'London'," & @CRLF & _
" 'age' : 26," & @CRLF & _
" 'isMarried' : True ," & @CRLF & _
" 'brothersNames' : ['Kim' , 'David' , 'Ron']" & @CRLF & _
"} " & @CRLF & _
"" & @CRLF & _
"animal = {" & @CRLF & _
" 'type' : 'Lion'," & @CRLF & _
" 'name' : 'Simba'," & @CRLF & _
" 'age' : 10," & @CRLF & _
"}"
Local $sSubst = "\1What an ugly design\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)