using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(person\s*=\s*{[^}]*'name'\s*:\s*')(.*?)(')";
string substitution = @"\1What an ugly design\3";
string input = @"person = {
'name' : 'Jhon Dow',
'address' : 'London',
'age' : 26,
'isMarried' : True ,
'brothersNames' : ['Kim' , 'David' , 'Ron']
}
animal = {
'type' : 'Lion',
'name' : 'Simba',
'age' : 10,
}";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}