$re = '/(person\s*=\s*{[^}]*\'name\'\s*:\s*\')(.*?)(\')/s';
$str = 'person = {
\'name\' : \'Jhon Dow\',
\'address\' : \'London\',
\'age\' : 26,
\'isMarried\' : True ,
\'brothersNames\' : [\'Kim\' , \'David\' , \'Ron\']
}
animal = {
\'type\' : \'Lion\',
\'name\' : \'Simba\',
\'age\' : 10,
}';
$subst = "\1What an ugly design\3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;