#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=\d)\s*(?=(?:st|nd|rd|th)\b)"
Local $sString = "foo 1 st, 2 nd, 33 rdfgs,33 rd,bar 134 th"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)