$re = '/^(.*?)\/+$/m';
$str = 'http://example.com///
http://emy.dod.com/kaskaa/dkaiad/amaa//////////
http://www.example.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);