using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\$(?:(?:\w+\.)+\w{2,})+(?:(?:\w+\/)+\w+)*$";
string input = @"$example.com
$example.com/invoices/12345
$bob.example.com
$example.com/bob
$ilp.uphold.com/PM3RAZfjyXWf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}