const regex = /<\d+>\S+\s(\d{4}-\d{2}-\d{2})\s(\d{2}\x3a\d{2}\x3a\d{2}),\d+\s\x5b\d+\x5d\s+\S+\s+\S+\s\S+\s+\S+\s+\S+\s\S+\s\ServerIPAddress\x3a\s\S+\s((?:\d{1,3}\x2e){3}\d{1,3})\s+ClientIPAddress\x3a\s(\S+)\s\S+\s\S+\s\S+\s\S+\s+\S+\s\S+\s+\S+\s\S+\s+\S+\s\S+\s+\S+\s+\S+\s+MessageText\x3a\s(Admin\sActivity)\s+UserId\x3a\s(\d+)\s+UserName\x3a\s(\S+)\s+Action\sDate\/Time\x3a\s+\S+\s\S+\s\S+\s+Portal\sGroup\sId\x3a\s(\d+)\s+Portal Group Name\x3a\s([a-zA-Z\s]+)\s+Action\sType\x3a\s([a-zA-Z\s]+)\sAction\sDetail\x3a([a-zA-Z0-9\.\;\s\:]+)\sArea\sOf\sAdministration\x3a\s(\S+)\s+Portal\sId\x3a\s(\d+)\s+Portal\sName\x3a\s([a-zA-Z0-9\s]+)\s+Enterprise\sUser\x3a\s(\S+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\d+>\\S+\\s(\\d{4}-\\d{2}-\\d{2})\\s(\\d{2}\\x3a\\d{2}\\x3a\\d{2}),\\d+\\s\\x5b\\d+\\x5d\\s+\\S+\\s+\\S+\\s\\S+\\s+\\S+\\s+\\S+\\s\\S+\\s\\ServerIPAddress\\x3a\\s\\S+\\s((?:\\d{1,3}\\x2e){3}\\d{1,3})\\s+ClientIPAddress\\x3a\\s(\\S+)\\s\\S+\\s\\S+\\s\\S+\\s\\S+\\s+\\S+\\s\\S+\\s+\\S+\\s\\S+\\s+\\S+\\s\\S+\\s+\\S+\\s+\\S+\\s+MessageText\\x3a\\s(Admin\\sActivity)\\s+UserId\\x3a\\s(\\d+)\\s+UserName\\x3a\\s(\\S+)\\s+Action\\sDate\\\/Time\\x3a\\s+\\S+\\s\\S+\\s\\S+\\s+Portal\\sGroup\\sId\\x3a\\s(\\d+)\\s+Portal Group Name\\x3a\\s([a-zA-Z\\s]+)\\s+Action\\sType\\x3a\\s([a-zA-Z\\s]+)\\sAction\\sDetail\\x3a([a-zA-Z0-9\\.\\;\\s\\:]+)\\sArea\\sOf\\sAdministration\\x3a\\s(\\S+)\\s+Portal\\sId\\x3a\\s(\\d+)\\s+Portal\\sName\\x3a\\s([a-zA-Z0-9\\s]+)\\s+Enterprise\\sUser\\x3a\\s(\\S+)', '')
const str = `<190>MedSeekBusinessServer.exe: 2016-08-08 09:04:06,965 [4] INFO MedSeek.Portal.Server.LoggingProvider.Data.AuditTrailSqlDao UserID: -9999 UserName: System ServerIPAddress: 10.247.82.26 10.247.82.112 ClientIPAddress: (null) PortalId: (null) PortalName: (null) AssemblyName: MedSeek.Portal.Server.LoggingProvider
ClassName: AuditTrailSqlDao
MethodName: LogToSysLog
CustomProps: 6ZalfDCycQw=
MessageText: Admin Activity
UserId: 301640
UserName: myost6
Action Date/Time: 8/8/2016 1:04:06 PM
Portal Group Id: 1273153
Portal Group Name: myCarolinas Admin
Action Type: Update User
Action Detail: User updated. User ID: 301640; UserName: myost6;
Area Of Administration: Users
Portal Id: 6
Portal Name: my Carolinas Mobile
Enterprise User: False
<190>MedSeekBusinessServer.exe: 2016-08-08 09:04:06,965 [4] INFO MedSeek.Portal.Server.LoggingProvider.Data.AuditTrailSqlDao UserID: -9999 UserName: System ServerIPAddress: 10.247.82.26 10.247.82.112 ClientIPAddress: (null) PortalId: (null) PortalName: (null) AssemblyName: MedSeek.Portal.Server.LoggingProvider
ClassName: AuditTrailSqlDao
MethodName: LogToSysLog
CustomProps: 6ZalfDCycQw=
MessageText: Admin Activity
UserId: 301640
UserName: myost6
Action Date/Time: 8/8/2016 1:04:06 PM
Portal Group Id: 1273153
Portal Group Name: myCarolinas Admin
Action Type: Update User
Action Detail: User updated. User ID: 301640; UserName: myost6;
Area Of Administration: Users
Portal Id: 6
Portal Name: my Carolinas Mobile
Enterprise User: False
<190>MedSeekBusinessServer.exe: 2016-08-08 09:04:12,815 [4] INFO MedSeek.Portal.Server.LoggingProvider.Data.AuditTrailSqlDao UserID: -9999 UserName: System ServerIPAddress: 10.247.82.26 10.247.82.112 ClientIPAddress: (null) PortalId: (null) PortalName: (null) AssemblyName: MedSeek.Portal.Server.LoggingProvider
ClassName: AuditTrailSqlDao
MethodName: LogToSysLog
CustomProps: 6ZalfDCycQw=
MessageText: Admin Activity
UserId: 244010
UserName: katdbod
Action Date/Time: 8/8/2016 1:04:12 PM
Portal Group Id: 1273153
Portal Group Name: myCarolinas Admin
Action Type: Update User
Action Detail: User updated. User ID: 244010; UserName: katdbod;
Area Of Administration: Users
Portal Id: 2
Portal Name: myCarolinas
Enterprise User: False
<190>MedSeekBusinessServer.exe: 2016-08-08 09:04:12,815 [4] INFO MedSeek.Portal.Server.LoggingProvider.Data.AuditTrailSqlDao UserID: -9999 UserName: System ServerIPAddress: 10.247.82.26 10.247.82.112 ClientIPAddress: (null) PortalId: (null) PortalName: (null) AssemblyName: MedSeek.Portal.Server.LoggingProvider%0D ClassName: AuditTrailSqlDao%0D MethodName: LogToSysLog%0D CustomProps: 6ZalfDCycQw=%0D MessageText: Admin Activity%0D UserId: 244010%0D UserName: katdbod%0D Action Date/Time: 8/8/2016 1:04:12 PM%0D Portal Group Id: 1273153%0D Portal Group Name: myCarolinas Admin%0D Action Type: Update User%0D Action Detail: User updated. User ID: 244010; UserName: katdbod; %0D Area Of Administration: Users%0D Portal Id: 2%0D Portal Name: myCarolinas%0D Enterprise User: False%0D
<190>MedSeekBusinessServer.exe: 2016-08-08 09:04:12,971 [4] INFO MedSeek.Portal.Server.LoggingProvider.Data.AuditTrailSqlDao UserID: -9999 UserName: System ServerIPAddress: 10.247.82.26 10.247.82.112 ClientIPAddress: (null) PortalId: (null) PortalName: (null) AssemblyName: MedSeek.Portal.Server.LoggingProvider%0D ClassName: AuditTrailSqlDao%0D MethodName: LogToSysLog%0D CustomProps: 6ZalfDCycQw=%0D MessageText: Admin Activity%0D UserId: 244010%0D UserName: katdbod%0D Action Date/Time: 8/8/2016 1:04:12 PM%0D Portal Group Id: 1273153%0D Portal Group Name: myCarolinas Admin%0D Action Type: Update User%0D Action Detail: User updated. User ID: 244010; UserName: katdbod; %0D Area Of Administration: Users%0D Portal Id: 2%0D Portal Name: myCarolinas%0D Enterprise User: False%0D
<190>MedSeekBusinessServer.exe: 2016-08-08 09:04:12,971 [4] INFO MedSeek.Portal.Server.LoggingProvider.Data.AuditTrailSqlDao UserID: -9999 UserName: System ServerIPAddress: 10.247.82.26 10.247.82.112 ClientIPAddress: (null) PortalId: (null) PortalName: (null) AssemblyName: MedSeek.Portal.Server.LoggingProvider%0D ClassName: AuditTrailSqlDao%0D MethodName: LogToSysLog%0D CustomProps: 6ZalfDCycQw=%0D MessageText: Admin Activity%0D UserId: 244010%0D UserName: katdbod%0D Action Date/Time: 8/8/2016 1:04:12 PM%0D Portal Group Id: 1273153%0D Portal Group Name: myCarolinas Admin%0D Action Type: Update User%0D Action Detail: User updated. User ID: 244010; UserName: katdbod; %0D Area Of Administration: Users%0D Portal Id: 2%0D Portal Name: myCarolinas%0D Enterprise User: False%0D
<190>MedSeekBusinessServer.exe: 2016-08-08 09:04:33,766 [4] INFO MedSeek.Portal.Server.LoggingProvider.Data.AuditTrailSqlDao UserID: -9999 UserName: System ServerIPAddress: 10.247.82.26 10.247.82.112 ClientIPAddress: (null) PortalId: (null) PortalName: (null) AssemblyName: MedSeek.Portal.Server.LoggingProvider%0D ClassName: AuditTrailSqlDao%0D MethodName: LogToSysLog%0D CustomProps: 6ZalfDCycQw=%0D MessageText: Admin Activity%0D UserId: 164664%0D UserName: rrrleigh%0D Action Date/Time: 8/8/2016 1:04:33 PM%0D Portal Group Id: 1273153%0D Portal Group Name: myCarolinas Admin%0D Action Type: Change User Password%0D Action Detail: Password changed for user. User ID: 164664; %0D Area Of Administration: Users%0D Portal Id: 2%0D Portal Name: myCarolinas%0D Enterprise User: False%0D
<190>MedSeekBusinessServer.exe: 2016-08-08 09:04:33,766 [4] INFO MedSeek.Portal.Server.LoggingProvider.Data.AuditTrailSqlDao UserID: -9999 UserName: System ServerIPAddress: 10.247.82.26 10.247.82.112 ClientIPAddress: (null) PortalId: (null) PortalName: (null) AssemblyName: MedSeek.Portal.Server.LoggingProvider%0D ClassName: AuditTrailSqlDao%0D MethodName: LogToSysLog%0D CustomProps: 6ZalfDCycQw=%0D MessageText: Admin Activity%0D UserId: 164664%0D UserName: rrrleigh%0D Action Date/Time: 8/8/2016 1:04:33 PM%0D Portal Group Id: 1273153%0D Portal Group Name: myCarolinas Admin%0D Action Type: Change User Password%0D Action Detail: Password changed for user. User ID: 164664; %0D Area Of Administration: Users%0D Portal Id: 2%0D Portal Name: myCarolinas%0D Enterprise User: False%0D
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}