#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(%[SCD-])+$"
Local $sString = "This will match:" & @CRLF & _
"%D%-" & @CRLF & _
"%S%C%S" & @CRLF & _
"" & @CRLF & _
"But will not match:" & @CRLF & _
"%%D%C" & @CRLF & _
"%D%%C" & @CRLF & _
"%DD%C" & @CRLF & _
"%DC%C"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")