# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/checked=.*?_value\\"//g;t' <<< "my regex expression checked=\\"someword_and_moreword_value\\""