package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`checked=.*?_value\\"`)
var str = `my regex expression checked=\"someword_and_moreword_value\"`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}