use strict;
my $str = 'my regex expression checked=\\"someword_and_moreword_value\\"';
my $regex = qr/checked=.*?_value\\"/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";