import Foundation
let pattern = ##"#([^\s\p{P}]*)\S+"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"Android Wear testen doen we met de Sony #Smartwatch3. Binnenkort volgt een uitgebreide review op de website ;-)"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="https://www.facebook.com/hashtag/$1" title="$1">$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)