import Foundation
let pattern = #"<div\s+username="pepper">(?:(?!<\/div>)[\s\S])*?location.*?\s+<td>([^<]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<div username="bob">
<table>
<tr>
<td>name</td>
<td>alex</td>
</tr>
<tr>
<td>location</td>
<td>London</td>
</tr>
<tr>
<td>id</td>
<td>123</td>
</tr>
</table>
</div>
<div username="apple">
<table>
<tr>
<td>name</td>
<td>david</td>
</tr>
<tr>
<td>id</td>
<td>321</td>
</tr>
</table>
</div>
<div username="pepper">
<table>
<tr>
<td>location</td>
<td>Bradford</td>
</tr>
</table>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)