using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w(s)\b)";
string substitution = @"\0 \1";
string input = @"Dress";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}