const regex = /(\w(s)\b)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w(s)\\b)', '')
const str = `Dress`;
const subst = `\0 \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);