#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<!(--(?:[^-]|-(?!->))*?--)>)(?!((?!<%--)[\s\S])*?--%>)"
Local $sString = "Condition: 1 : <!-- normal HTML comment -->" & @CRLF & _
"" & @CRLF & _
"Codition: 2 <%-- normal JSP comment " & @CRLF & _
" <!-- inside html comment here -->" & @CRLF & _
" other comment stuff" & @CRLF & _
" <!-- another inside html comment here -->" & @CRLF & _
"--%>" & @CRLF & _
"Condition: 1 : <!-- normal HTML comment -->" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "<%$2%>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)