using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<!(--(?:[^-]|-(?!->))*?--)>)(?!((?!<%--)[\s\S])*?--%>)";
string substitution = @"<%$2%>";
string input = @"Condition: 1 : <!-- normal HTML comment -->
Codition: 2 <%-- normal JSP comment
<!-- inside html comment here -->
other comment stuff
<!-- another inside html comment here -->
--%>
Condition: 1 : <!-- normal HTML comment -->
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}