use strict;
my $str = 'Condition: 1 : <!-- normal HTML comment -->
Codition: 2 <%-- normal JSP comment
<!-- inside html comment here -->
other comment stuff
<!-- another inside html comment here -->
--%>
Condition: 1 : <!-- normal HTML comment -->
';
my $regex = qr/(<!(--(?:[^-]|-(?!->))*?--)>)(?!((?!<%--)[\s\S])*?--%>)/p;
my $subst = '<%$2%>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";