$re = '/(<!(--(?:[^-]|-(?!->))*?--)>)(?!((?!<%--)[\s\S])*?--%>)/';
$str = 'Condition: 1 : <!-- normal HTML comment -->
Codition: 2 <%-- normal JSP comment
<!-- inside html comment here -->
other comment stuff
<!-- another inside html comment here -->
--%>
Condition: 1 : <!-- normal HTML comment -->
';
$subst = "<%$2%>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;