$re = '/(?:[^a-zA-Z0-9]*[a-zA-Z0-9]){3}.*/m';
$str = '\'a3c\'
\'_0_c_8_\'
\' 9 9d \'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);