use strict;
my $str = 'class GTECostSheetFactorParameters';
my $regex = qr/([ ]*)(class)[ ]+([a-zA-Z]\S*).*/p;
my $subst = 'protected void new()\\n{\\n}\\n\\npublic static \\3 construct()\\n{\\n\\treturn new \\3();\\n}\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";