# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-zA-Z]\d([a-zA-Z]|\d)(.([a-zA-Z]|\d){1,4})?"
test_str = ("L89.141 – Pressure ulcer of left lower back, stage 1\n"
"L89.142 – Pressure ulcer of left lower back, stage 2\n"
"L89.143 – Pressure ulcer of left lower back, stage 3\n"
"L89.144 – Pressure ulcer of left lower back, stage 4\n"
"L89.149 – Pressure ulcer of left lower back, unspecified stage\n"
"L89.151 – Pressure ulcer of sacral region, stage 1\n"
"L89.152 – Pressure ulcer of sacral region, stage 2\n\n"
"A12.123a\n"
"123.1\n"
"B23\n"
"B12.\n\n"
"B12.321assdf\n"
"12B23.234a ds")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.