// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r#"(?<remote>[^ ]*) - (?<user>[^ ]*) \[(?<time>[^\]]*)\] "(?<method>\S+)(?: +(?<path>[^\"]*) +\S*)?" (?<code>[^ ]*) (?<size>[^ ]*)(?: "(?<referer>[^\"]*)" "(?<agent>[^\"]*)")? (?<request_time>[^ ]*) (?<upstream_response_time>[^ ]*)"#).unwrap();
  let string = "115.192.115.147 - - [04/Dec/2015:01:08:03 +0800] \"GET /n
otify HTTP/1.1\" 200 0 \"-\" \"Android/19 (cynovo-par10; DRX-1.1.2-20151103-H7; root; unknown; zh_CN) com.luedongtech.kr3000/231 00:23:9e:03:49:5b\" 0.004 0.004
";
  
  // result will be a tuple containing the start and end indices for the first match in the string
  let result = regex.captures(string);
  
  let (start, end) = match result {
    Some((s, e)) => (s, e),
    None => {
        // ...
    }
  };
  
  
  println!("{}", &string[start, end]);
}