$re = '/\/\*[\s\S]*\*\//i';
$str = 'read A
read B
sum := A + B
write sum
// Inline comment
/*
multiline comment
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);