$re = '/^\s*$\n|\r/m';
$str = ' <Formula>
double dn=a+b;
if (dn==0) then
return 0;
return (c+d)/dn;;
</Formula>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;