# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\t\t\t\tcompile: function\s*\([^)]+\)\s*\{\s*return\s+function\s*\(\s*([^)]+)\s*\)\s*\{\s*([^}]+?)\s*};\s+}/\t\t\t\tlink: function($1) {\n\t\t\t\t\t$2\n\t\t\t\t}/;t' <<< " compile: function(element, attrs, childTranscludeFn) {
return function ( scope, element, attrs, checkboxCtrl ) {
checkboxCtrl.init(scope.$parent.element);
};
}"