using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\t\t\t\tcompile: function\s*\([^)]+\)\s*\{\s*return\s+function\s*\(\s*([^)]+)\s*\)\s*\{\s*([^}]+?)\s*};\s+}";
string substitution = @"\t\t\t\tlink: function($1) {\n\t\t\t\t\t$2\n\t\t\t\t}";
string input = @" compile: function(element, attrs, childTranscludeFn) {
return function ( scope, element, attrs, checkboxCtrl ) {
checkboxCtrl.init(scope.$parent.element);
};
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}