#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:http(?:s)?:\/\/)?(?:www\.|\w\w\.)?linkedin\.com\/((?:in)\/(?:[a-zA-Z0-9-]{5,30}(?:\/)?)|(?:profile\/)(?:view\?id=[0-9]+))?$"
Local $sString = "es.linkedin.com/pub/francisco-fernandez/30/14/62" & @CRLF & _
"https://www.linkedin.com/profile/view?id=107523146" & @CRLF & _
"de.linkedin.com/pub/frank-rempp/1/638/7a1" & @CRLF & _
"http://uk.linkedin.com/pub/some-name/1/1b3/b45/" & @CRLF & _
"http://nl.linkedin.com/pub/other-name/11/223/544" & @CRLF & _
"http://www.linkedin.com/in/aname/" & @CRLF & _
"http://www.linkedin.com/in/another-name" & @CRLF & _
"http://linkedin.com/in/nameaaaa" & @CRLF & _
"http://nl.linkedin.com/in/namela" & @CRLF & _
"http://nl.linkedin.com/in/nameaaa/" & @CRLF & _
"https://www.linkedin.com/in/myname-v-98797987897798/" & @CRLF & _
"https://www.linkedin.com/in/jessie-vandevoorde-a60035102/" & @CRLF & _
"https://www.linkedin.com/company/somecompany/" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)