use strict;
my $str = 'es.linkedin.com/pub/francisco-fernandez/30/14/62
https://www.linkedin.com/profile/view?id=107523146
de.linkedin.com/pub/frank-rempp/1/638/7a1
http://uk.linkedin.com/pub/some-name/1/1b3/b45/
http://nl.linkedin.com/pub/other-name/11/223/544
http://www.linkedin.com/in/aname/
http://www.linkedin.com/in/another-name
http://linkedin.com/in/nameaaaa
http://nl.linkedin.com/in/namela
http://nl.linkedin.com/in/nameaaa/
https://www.linkedin.com/in/myname-v-98797987897798/
https://www.linkedin.com/in/jessie-vandevoorde-a60035102/
https://www.linkedin.com/company/somecompany/
';
my $regex = qr/^(?:http(?:s)?:\/\/)?(?:www\.|\w\w\.)?linkedin\.com\/((?:in)\/(?:[a-zA-Z0-9-]{5,30}(?:\/)?)|(?:profile\/)(?:view\?id=[0-9]+))?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";