#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<td.*(File)(<[^>]*>)*:(<[^>]*>)*([\w])+\.(jpg).*td>"
Local $sString = "<td class='diff-addedline'><div>[[<ins class=\"diffchange diffchange-inline\">File<\/ins>:<ins class=\"diffchange diffchange-inline\">Colt3<\/ins>.jpg|thumb|none|350px|Colt 1895 machine gun .30-40 Krag]]<\/div><\/td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")