import Foundation
let pattern = #"<td.*(File)(<[^>]*>)*:(<[^>]*>)*([\w])+\.(jpg).*td>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<td class='diff-addedline'><div>[[<ins class=\"diffchange diffchange-inline\">File<\/ins>:<ins class=\"diffchange diffchange-inline\">Colt3<\/ins>.jpg|thumb|none|350px|Colt 1895 machine gun .30-40 Krag]]<\/div><\/td>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}