$re = '/^(?!0)\d{1,4}(?:\.\d\d?)?$/m';
$str = '0
1
9
01
10
333
9998
9999
10000
abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);