const regex = /(?<=[.])(?=[^\s])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[.])(?=[^\\s])', 'gm')
const str = `The two platinum derivatives have been previously combined as they are not totally cross-resistant and as they share no overlapping toxicities.Patients with AOC, after the initial cytoreductive surgery were randomized to either 6 courses of paclitaxel at 175 mg/m2 as 3 h infusion plus Carboplatin at 7 AUC (Arm A) or Paclitaxel at the same dose plus Carboplatin again at 7 AUC for cycles 1,3,5, while for cycles 2,4,6 Cisplatin at 75 mg/m2 substituted for Carboplatin (Arm B).247 patients are analyzed.`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);