package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`variable1=([^&]*?)&variable2=([^&]*?)`)
var str = `script.php?variable1=value1&variable2=value2&variable3=value3&.........................`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}