import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z]\\d{1,2}|[A-Z]{2}\\d(\\d|[A-Z])?)( \\d[A-Z]{2})?$";
final String string = "1 Letter 1 Number\n"
+ "E2\n"
+ "1 Letter 2 Numbers\n"
+ "E22\n"
+ "2 Letters 1 Number\n"
+ "EE2\n"
+ "2 Letters 1 Number 1 Letter\n"
+ "EE2E\n"
+ "2 Letters 2 Numbers\n"
+ "EE22\n"
+ "1 Letter 1 Number (Space) 1 Number 2 Letters\n"
+ "E2 2EE\n"
+ "1 Letter 2 Numbers (Space) 1 Number 2 Letters\n"
+ "E22 2EE\n"
+ "2 Letters 1 Number (Space) 1 Number 2 Letters\n"
+ "EE2 2EE\n"
+ "2 Letters 1 Number 1 Letter (Space) 1 Number 2 Letters\n"
+ "EE2E 2EE\n"
+ "2 Letters 2 Numbers (Space) 1 Number 2 Letters\n"
+ "EE22 2EE\n\n"
+ "6FW OX28\n"
+ "82XO 6FW\n"
+ "OX28 6FW\n\n"
+ "E2E\n"
+ "E22E\n"
+ "E33 33E";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}