#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\+|00)?\d{1,3})?[1-9][0-9]{9}$"
Local $sString = "+449807093606" & @CRLF & _
"00449807093606" & @CRLF & _
" is valid in my regex pattern, " & @CRLF & _
"wanted to make valid for " & @CRLF & _
"+446707093606" & @CRLF & _
"446707093606" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")