use strict;
my $str = '+449807093606
00449807093606
is valid in my regex pattern,
wanted to make valid for
+446707093606
446707093606
';
my $regex = qr/^((\+|00)?\d{1,3})?[1-9][0-9]{9}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}