import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*([JSESSIONID]+)\\s*=\\s*(?:\"([^\"])\"|([^;\"]*))\\s*";
final String string = "HTTP/1.1 302 Found\n"
+ "Date: Fri, 10 Jun 2016 21:44:38 GMT\n"
+ "Set-Cookie: JSESSIONID=1n9rk5co2o4xkpr327clod1pu;Path=/genesys;Expires=Sat, 11-Jun-2016 21:44:38 GMT;HttpOnly\n"
+ "Expires: Thu, 01 Jan 1970 00:00:00 GMT\n"
+ "Location: http://192.168.1.200:8010/genesys/admin/login.jsp#/\n"
+ "Content-Length: 0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}