$re = '/^[\u0967-\u096F][\u0966-\u096F]*$/m';
$str = '१२३४१५६à¥à¥®à¥¯';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);