#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<iframe\s+.*?\s+src=(".*?").*?<\/iframe>"
Local $sString = "<p><iframe allowfullscreen="" class="media-element file-default" data-fid="2219" data-media-element="1" frameborder="0" height="360" src="https://www.youtube.com/embed/sNEJOm4hSaw?feature=oembed" width="640"></iframe></p>"
Local $sSubst = "<a href=$1>Link to youtube</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)