$re = '/^(?![^\/$-]*[\/$-]{2})[\w\/$-]+(?<![\/-])$/m';
$str = 'String of any length that can be alphanumeric with $,-, or /, but does not match when it contains more than two of these non-alphanumeric characters in a row, or ends with / or -
Hello/World
Hello//World
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);