$re = '/^[1-9][0-9]+(\.[0-9]+)?(MB|GB|TB)$/i';
$str = '10.40TB';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);