re = /,([a-zA-Z].*?)(?=,[a-zA-Z]|$)/m
str = 'a=b,1,2,3,4,c=34,76,67,54,bc=78,45,h=565,64'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end