using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<name>[\w\s]+)(?: <(?P<email>[^>]+)>)?$";
string input = @"John Doe <john.doe@example.com>
John Doe <john.doe!!!???äöu@exämple.com>
John Doe<john.doe@example.com>
<john.doe@example.com>
john.doe@example.com
John Doe john.doe@example.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}