#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(^F.*$)|(^BBC.*$))"
Local $sString = "F1" & @CRLF & _
"BBC450" & @CRLF & _
"BBC566" & @CRLF & _
"F2" & @CRLF & _
"F31" & @CRLF & _
"SOMETHING123" & @CRLF & _
"SOMETHING456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")