import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(^F.*$)|(^BBC.*$))";
final String string = "F1\n"
+ "BBC450\n"
+ "BBC566\n"
+ "F2\n"
+ "F31\n"
+ "SOMETHING123\n"
+ "SOMETHING456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}